Server compiling not working for me...

Post Reply
Amodin
Posts: 8
Joined: Sat Sep 22, 2018 2:42 am

Server compiling not working for me...

Post by Amodin » Sat Sep 22, 2018 3:03 am

Like a few others, compiling seems to be a problem and the common theme is 'SDK version needs to get installed' is what I'm reading. I've done that and still have a catastrophic failure with compiling.

My setup is a Windows 2012 Server in a VMWare environment. I am forced to use VS2015 or older on the server, as VS2017 won't install on this server unless I had R2 version (which I don't). I have compiled two Asheron's Call servers already on here and has been set up flawless, but this project is a bit of a pain.

I've attached a text file of my problems when compiling, as they are C1083 errors. It seems the include:any statements is the main hated culprit, and if you rem those out, it gets worse, so I'm back at square one. I have MariaDB up and running and the database was created and populated flawless. So, the DB is there, and if I can get some assistance on compiling, that would be great. I've installed just about every SDK and VCdist I can install, but not sure where to go from here. I've re-downloaded the master-stable enough times to gag a horse.
Attachments
garbage setup.txt
Setup log
(41.3 KiB) Downloaded 13 times

jono659
Posts: 50
Joined: Sat Mar 24, 2018 1:01 pm

Re: Server compiling not working for me...

Post by jono659 » Sat Sep 22, 2018 5:31 am

Don't think it will compile on VS2015 bud sorry. And as you are already aware, you cannot install 2017 on 2012. Only way I can think is install 2012 R2 on a VM with a trial licence. I have done this and works a treat for 18 months ^.^

User avatar
TeoTwawki
Developer
Posts: 516
Joined: Mon Jul 15, 2013 9:50 pm
Contact:

Re: Server compiling not working for me...

Post by TeoTwawki » Sat Sep 22, 2018 6:06 am

vs2017 will in fact work on the "R2" version of windows server 2012, IF you are fully updated (run those windows updates). If not R2 or not updated the visual studio won't install.
https://docs.microsoft.com/en-us/visualstudio/productinfo/vs2017-system-requirements-vs wrote:Visual Studio 2017 will install and run on the following operating systems:
•Windows 10 version 1507 or higher: Home, Professional, Education, and Enterprise (LTSC and S are not supported)
•Windows Server 2016: Standard and Datacenter
•Windows 8.1 (with Update 2919355): Core, Professional, and Enterprise
•Windows Server 2012 R2 (with Update 2919355): Essentials, Standard, Datacenter
•Windows 7 SP1 (with latest Windows Updates): Home Premium, Professional, Enterprise, Ultimate
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

jono659
Posts: 50
Joined: Sat Mar 24, 2018 1:01 pm

Re: Server compiling not working for me...

Post by jono659 » Sat Sep 22, 2018 8:20 am

He was saying he doesn't have R2 Teo.

Amodin
Posts: 8
Joined: Sat Sep 22, 2018 2:42 am

Re: Server compiling not working for me...

Post by Amodin » Sat Sep 22, 2018 10:13 am

Correct, VS2017 will only work on R2 version of 2012 server, I don't have that, just Server 2012. :) I think you misunderstood what I said.

What if I were to compile it on a Win 10 machine and then move that folder to the server once compiled? What would I need to change there? The db and entire directory would be hosted on that server at that point, and not access a secondary server or anything like that.

jono659
Posts: 50
Joined: Sat Mar 24, 2018 1:01 pm

Re: Server compiling not working for me...

Post by jono659 » Mon Sep 24, 2018 12:28 am

Dont need the db bro, just the copy the dark-star folders to the win 10 machine, then compile and copy the 6 files from the darkstar root directory across to the server. There are 1 exe and 1 pdb for the connect, game and search servers. Job done.

Amodin
Posts: 8
Joined: Sat Sep 22, 2018 2:42 am

Re: Server compiling not working for me...

Post by Amodin » Thu Sep 27, 2018 3:38 pm

That worked! Thanks so much for the help. NSSM even works well to keep the services running.

jono659
Posts: 50
Joined: Sat Mar 24, 2018 1:01 pm

Re: Server compiling not working for me...

Post by jono659 » Fri Sep 28, 2018 1:02 am

Well done bro, glad I could help. If you want any of my scripts gimme a shout.

User avatar
TeoTwawki
Developer
Posts: 516
Joined: Mon Jul 15, 2013 9:50 pm
Contact:

Re: Server compiling not working for me...

Post by TeoTwawki » Sun Sep 30, 2018 3:07 pm

jono659 wrote:
Sat Sep 22, 2018 8:20 am
He was saying he doesn't have R2 Teo.
completely missed it, my bad. speed read fail.
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

Post Reply