error last update - Ubuntu server

Post Reply
Posts: 175
Joined: Thu Mar 13, 2014 10:15 pm
Location: Hawkesbury, Ontario, CANADA

error last update - Ubuntu server

Post by Alexandre24 » Sun Nov 26, 2017 1:15 pm

Hello everyone!

I want compile the last update for my ubuntu server, and I found a error. One idea? Thanks!

server@debian:~/darkstar$ make
g++ -std=c++17 -DHAVE_CONFIG_H -I. -I./src/common -fsigned-char -DFMT_HEADER_ONLY -DdsUDPSERV -fsigned-char -I/usr/include/luajit-2.0 -I/usr/include/mysql -fsigned-char -g -O2 -MT dsgame-kernel.o -MD -MP -MF .deps/dsgame-kernel.Tpo -c -o dsgame-kernel.o `test -f 'src/common/kernel.cpp' || echo './'`src/common/kernel.cpp
In file included from src/common/kernel.cpp:27:0:
src/common/../common/taskmgr.h:32:15: fatal error: any: No such file or directory
compilation terminated.
Makefile:1905: recipe for target 'dsgame-kernel.o' failed
make: *** [dsgame-kernel.o] Error 1

User avatar
Posts: 9
Joined: Sun Nov 19, 2017 7:25 pm

Re: error last update - Ubuntu server

Post by Zynjec » Tue Nov 28, 2017 1:47 pm

Make sure you've installed gcc-7 and used update-alternatives to actually point to it, it's likely using gcc5 still.
add-apt-repository -y ppa:ubuntu-toolchain-r/test
apt-get update
apt-get install -y g++-7
update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-7 90

Posts: 1
Joined: Mon Dec 11, 2017 6:23 am

Re: error last update - Ubuntu server

Post by kogenta » Mon Dec 11, 2017 6:31 am

Although this is a bit late, you may also need to install the development libraries. Specifically the 32-bit ones if you are on a 64-bit system.

I ran the following apt-get command and my compilation worked
apt-get install libx32gcc-7-dev

Post Reply