Having difficulty setting up the server

Post Reply
ClanMcCracken
Posts: 26
Joined: Sun Mar 25, 2018 8:54 am

Having difficulty setting up the server

Post by ClanMcCracken » Sun Mar 25, 2018 11:38 am

Hello everyone
I really enjoyed FFxi back in the day was was pretty excited about starting up my own server so my friend and I could play together by own selves (We actually met on FFxi) anyway, I am not too familiar with SQL or anything like that so I've been taking this pretty slowly and unsurprisingly nothing seems to be working. I dont even know if installing this is possible because I am on a windows 10 machine, instead of windows 7

I started off by attempting to download the prerequisites, and there is where the problem started. First I downloaded mysql server 5.7 and went from there but when I got to the point where I made the Bat file to import all of the files into the database, I changed the file address to where I had installed MySql and changed the password to what I set. But did not create the table so everything else was a string of errors. At that point I went back and uninstalled everything and started over. I attempted to install mysql server 5.6 but 5.6 wont install. The install bar gets about half way along the "Configure Mysql Installer" and just hangs up. I've been staring at it for over an hour and the bar isn't moving.

I guess my main questions at this point are: is this private server compatable with windows 10, and can i use MySql Server 5.7?

Sorry for my noob questions, and thank you for your time.

User avatar
whasf
Site Admin
Posts: 1287
Joined: Thu Jul 19, 2012 9:11 pm

Re: Having difficulty setting up the server

Post by whasf » Sun Mar 25, 2018 10:11 pm

Yes to both
-- Whasf

ClanMcCracken
Posts: 26
Joined: Sun Mar 25, 2018 8:54 am

Re: Having difficulty setting up the server

Post by ClanMcCracken » Fri Mar 30, 2018 3:56 pm

Thank you for the reply. I've finally got MySQL 5.7 installed and I'm ready to move onto the next step, I created the bat file as per the instructions, updated the file paths and the password, but when I place the file inside my darkstar/sql folder and run it I'm getting a whole string of errors. I can confirm that the MySQL service is currently running, the file path is correct, and the passwords are correct. Here is the code (password redacted), and the errors im getting. What am I doing wrong?

Code: Select all

ECHO Creating Database dspdb
"c:\Program Files\MySQL\MySQL Server 5.7\bin\mysqladmin"-h localhost -u root -pS*******9 DROP dspdb

ECHO Creating Database dspdb
"c:\Program Files\MySQL\MySQL Server 5.7\bin\mysqladmin"-h localhost -u root -pS*******9 CREATE dspdb

ECHO Loading dspdb tables into the database
cd c:\darkstar\sql
FOR %%X IN (*.sql) DO ECHO Importing %%X & "c:\Program Files\MySQL\MySQL Server 5.7\bin\mysql" dspdb -h localhost -u root -pS*******9 < %%X

ECHO Finished!

Code: Select all

Creating Database dspdb
'"c:\Program Files\MySQL\MySQL Server 5.7\bin\mysqladmin"-h' is not recognized as an internal or external command,
operable program or batch file.
Creating Database dspdb
'"c:\Program Files\MySQL\MySQL Server 5.7\bin\mysqladmin"-h' is not recognized as an internal or external command,
operable program or batch file.
Loading dspdb tables into the database
The system cannot find the path specified.
Importing abilities.sql
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1049 (42000): Unknown database 'dspdb'
Importing abilities_charges.sql
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1049 (42000): Unknown database 'dspdb'
...
and the errors continue for every sql file in my /sql folder

Your help would be very much appreciated, Thank you

User avatar
whasf
Site Admin
Posts: 1287
Joined: Thu Jul 19, 2012 9:11 pm

Re: Having difficulty setting up the server

Post by whasf » Fri Mar 30, 2018 4:11 pm

It's because your second line (that creates the database) errored out, so it can't import the tables.
-- Whasf

ClanMcCracken
Posts: 26
Joined: Sun Mar 25, 2018 8:54 am

Re: Having difficulty setting up the server

Post by ClanMcCracken » Fri Mar 30, 2018 4:29 pm

Any idea what the error could be? or where I should look to find the error?

User avatar
whasf
Site Admin
Posts: 1287
Joined: Thu Jul 19, 2012 9:11 pm

Re: Having difficulty setting up the server

Post by whasf » Fri Mar 30, 2018 6:24 pm

put a space between the quote and -h and see if that helps. Check to make sure mysqladmin.exe is in that folder (you may not have loaded the command line tools when you installed it)
-- Whasf

ClanMcCracken
Posts: 26
Joined: Sun Mar 25, 2018 8:54 am

Re: Having difficulty setting up the server

Post by ClanMcCracken » Fri Mar 30, 2018 6:38 pm

I added the space, per your suggestion, and I think it worked. There was a prompt asking me if I wanted to drop the table and it took much longer for it to work its way through the script. Probably close to 20 seconds, rather than 5.

Code: Select all

Creating Database dspdb
mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Dropping the database is potentially a very bad thing to do.
Any data stored in the database will be destroyed.

Do you really want to drop the 'dspdb' database [y/N] y
mysqladmin: DROP DATABASE dspdb failed;
error: 'Can't drop database 'dspdb'; database doesn't exist'
Creating Database dspdb
mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Loading dspdb tables into the database
The system cannot find the path specified.
Importing abilities.sql
mysql: [Warning] Using a password on the command line interface can be insecure.
Importing abilities_charges.sql
mysql: [Warning] Using a password on the command line interface can be insecure.
Importing accounts.sql
... ect
though that line about the system cannot find the path specified is a little worrying

ClanMcCracken
Posts: 26
Joined: Sun Mar 25, 2018 8:54 am

Re: Having difficulty setting up the server

Post by ClanMcCracken » Fri Mar 30, 2018 10:43 pm

Thank you for your help, the server side is up and running, now for the client side.

PoL is currently updating.

Post Reply