Wiki Client Setup Guide

rezza
Posts: 11
Joined: Fri May 10, 2013 10:24 am

Re: Wiki Client Setup Guide

Post by rezza » Sat May 11, 2013 4:54 pm

Would it be possible to get updated links for client-related files on the wiki page?
For example, both:
http://kile.dyndns.info:8765/bak/Ashita_Darkstar.zip
http://kile.dyndns.info:8765/bak/PXI-FF ... ePatch.zip
are throwing errors and it seems like a blocker for getting a client set up.
Many thanks!

~Rezza

doghusky1990
Posts: 56
Joined: Wed Aug 01, 2012 2:26 pm

Re: Wiki Client Setup Guide

Post by doghusky1990 » Sat May 11, 2013 8:06 pm

until it is fixed, you can get the ashita_Darkstar from http://forums.dspt.info/viewtopic.php?f=12&t=503.

rezza
Posts: 11
Joined: Fri May 10, 2013 10:24 am

Re: Wiki Client Setup Guide

Post by rezza » Mon May 13, 2013 2:18 pm

Much appreciated, I'll have a look.

doghusky1990
Posts: 56
Joined: Wed Aug 01, 2012 2:26 pm

Re: Wiki Client Setup Guide

Post by doghusky1990 » Mon May 13, 2013 3:45 pm

not a problem. :)

jackal
Posts: 2
Joined: Fri Oct 25, 2013 9:09 am

Re: Wiki Client Setup Guide

Post by jackal » Sun Oct 27, 2013 1:47 am

Hello there! New user here, and I'm having a harder time logging onto my server than setting the thing up, haha! I have a (working, i assume) server on an ubuntu laptop, and a test computer with an updated ffxi/pol. All i need is something to log in to a nonstandard server IP.

All of the ashita links in this thread (and wiki) are broken for me. Is the version on ffevo okay to use? I didn't think it would be, since the ones here are labeled "darkstar version"

If that one's okay to use, i just need to learn how to use git and a compiler on windows i guess. Why can't everything be as easy as it is on linux? :evil:

(EDIT: found, installed, and updated ashita. servers are running in console windows and have been stable now for hours. only problem now is that my ffxi-boot_mod pol.exe drops off every time i try to connect to a server, even when running from an administrator command prompt. i'm successfully logging into the "connect" server, but then something's going wrong and the game isn't loading. happens whether i'm attempting my local server or the darkstar test/classic servers)

ruin2it3
Posts: 5
Joined: Thu May 30, 2013 5:20 pm

Re: Wiki Client Setup Guide

Post by ruin2it3 » Mon Jun 04, 2018 1:19 am

Ok, so necro like a mofo, but...
Maybe it's just me, but the link in OP is mangled. Instead of sending me to the intended page it gives me

Code: Select all

https://wiki.dspt.infoindex.php/?title=Configuring_Your_Client
Working link for the client config was found at https://wiki.dspt.info/index.php/Config ... our_Client

Also Ashita can be found over at http://ashita.atom0s.com/


Ok, back to the graveyard, need a "date" for next weekend....

Clinton769
Posts: 2
Joined: Tue Oct 09, 2018 12:03 pm

Re: Wiki Client Setup Guide

Post by Clinton769 » Tue Oct 09, 2018 12:49 pm

Hello all, new here and how I've been missing out on this golden goose this long is beyond me, but anyway....

I'm not quite understanding the client side setup, especially in the version dept. Please correct my thinking here...

I haven't played retail in prolly about 1.5 years, maybe a little less, but I still have it installed on my machine. I downloaded the dspdb last night and started all the importing and server build and to me all that was straightforward and easy, but where I'm getting lost is how do you match up the dspdb server version against the client side version? In my head, if I connect to POL and update then I will have cutting edge current client trying to log into whatever version the dspdb server is frozen at which sounds to me like a problem issue.

In the setup guide, at the end it talks about everytime a patch comes out you have to update client thru POL, then drop the linked patch into your ffxi folder and do the check files again. Won't this action start the POL update again and you end up where you started? And maybe I'm misunderstanding how the project really works. This may be bad phrasing but isn't the loader (xiloader) somewhat hijacking or bypassing the POL launcher and directing the game to these private servers instead of retail? And if that is the case why would you ever need to update the client if the dspserver doesn't get modified? It seems to me that going private would negate the need to ever talk to POL again at all. What am I missing here?

The end goal for me is to run a local in house server for my family since we have loved this game since the dawn of time, and I was part of the closed beta, so ive been in game since the VERY beginning, but like may others out there, was very disappointed at were the game has landed and since no truly "new" content will be coming out anymore I just can't bring myself to continue to spend the same amount of money as day one. They've gotten greedy in my opinion and could easily come off the subscription price. Plus I'm VERY interested in making a few changes that I would have loved to have back in the old school days.

But hey, thanks in advance for any help or direction you can give me, and to the devs and guys that keep driving this project forward...... I tip my hat and raise a glass in your honor!! Keep up the excellent work!!!

User avatar
TeoTwawki
Developer
Posts: 516
Joined: Mon Jul 15, 2013 9:50 pm
Contact:

Re: Wiki Client Setup Guide

Post by TeoTwawki » Sat Oct 13, 2018 7:04 am

then drop the linked patch into your ffxi folder and do the check files again.
you don't have to re-patch every time. you can just delete rom/0/0.dat while in the version selection menu for the file check. it'll replace 0.dat during the update.
This may be bad phrasing but isn't the loader (xiloader) somewhat hijacking or bypassing the POL launcher and directing the game to these private servers instead of retail? And if that is the case why would you ever need to update the client if the dspserver doesn't get modified? It seems to me that going private would negate the need to ever talk to POL again at all. What am I missing here?
In order to continue to work on it we keep updating to current retail ( we need our client to connect with both retail and our project). if you never update your server you won't need to update your client either. there is also a setting in version.info you can adjust to allow wrong version clients at your own risk. you may see errors such as objects with the wrong name or the wrong dialog/text strings used in game, or the occasional broken cut scene event.
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

Post Reply