usable items crash the clients connected to my server

Can't get the client or server set up? Ask here!
We're on Discord! https://discord.gg/4dgAzfC
User avatar
TeoTwawki
Developer
Posts: 523
Joined: Mon Jul 15, 2013 9:50 pm

usable items crash the clients connected to my server

Post by TeoTwawki » Fri Aug 16, 2013 5:37 pm

I seem to have done something that broke all usable items on my server. Spell scrolls, food, enchanted gear, potions...Everything. No errors show on the server at all, but clients crash when they try to use an item. This doesn't happen on other servers I checked so it has to be something I did, but I've no idea where to look. I never made any edits that relate to items. Out of what little I did edit, I can't see where anything would do this.
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

doghusky1990
Posts: 56
Joined: Wed Aug 01, 2012 2:26 pm

Re: usable items crash the clients connected to my server

Post by doghusky1990 » Fri Aug 16, 2013 6:42 pm

I would delete your item folder located in "server/scripts/globals/"
then navigate to your back up a folder
and right click on globals and click svn update. This should fix any problems, if there was related to the items luas...

User avatar
TeoTwawki
Developer
Posts: 523
Joined: Mon Jul 15, 2013 9:50 pm

Re: usable items crash the clients connected to my server

Post by TeoTwawki » Fri Aug 16, 2013 8:55 pm

I wiped the entire thing, used a pure unchanged copy from svn. Crashed on using a meat jerky. Crashed on using a potion.

Darkstar test server I can use that same potion without problems from the same client. /headdesk
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

doghusky1990
Posts: 56
Joined: Wed Aug 01, 2012 2:26 pm

Re: usable items crash the clients connected to my server

Post by doghusky1990 » Fri Aug 16, 2013 8:59 pm

Is your database updated??
Have you update your copy of ffxi to the latest??
Also what client are u using??

User avatar
TeoTwawki
Developer
Posts: 523
Joined: Mon Jul 15, 2013 9:50 pm

Re: usable items crash the clients connected to my server

Post by TeoTwawki » Fri Aug 16, 2013 9:32 pm

Latest ffxi, latest ffxi boot with hairpin support, latest ashita, database was clean from svn* on that last test. I am so massively stumped.

* (dropped entire thing and used a new one, have my backup but have not restored anything yet)
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

User avatar
TeoTwawki
Developer
Posts: 523
Joined: Mon Jul 15, 2013 9:50 pm

Re: usable items crash the clients connected to my server

Post by TeoTwawki » Sun Aug 18, 2013 1:56 pm

What else is left? I compiled a completely separate server with a totally new database and still have items crashing, and if it were the client I'd be crashing on the test server too and I'm not. Could I somehow have a damaged runtime or something on the server's OS and not be getting an error message during compile?

The only thing I can think of is to try a new build on a totally different physical machine and see if it still happens. That's gonna take awhile. :/
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

doghusky1990
Posts: 56
Joined: Wed Aug 01, 2012 2:26 pm

Re: usable items crash the clients connected to my server

Post by doghusky1990 » Sun Aug 18, 2013 2:08 pm

I might be able to upload my copy for you if you want it...

ps. i am uploading it now, so, if you want it, I will give you the link when it is done.

User avatar
kjLotus
Lead Developer
Posts: 1813
Joined: Sun Jul 22, 2012 2:16 pm

Re: usable items crash the clients connected to my server

Post by kjLotus » Sun Aug 18, 2013 3:02 pm

if you have hairpin on, try turning that off

User avatar
whasf
Site Admin
Posts: 1294
Joined: Thu Jul 19, 2012 9:11 pm

Re: usable items crash the clients connected to my server

Post by whasf » Sun Aug 18, 2013 6:34 pm

What version does ffxi show at the title screen?
-- Whasf

User avatar
TeoTwawki
Developer
Posts: 523
Joined: Mon Jul 15, 2013 9:50 pm

Re: usable items crash the clients connected to my server

Post by TeoTwawki » Mon Aug 19, 2013 3:32 pm

It's the hairpin option >.<

Thank you so much for your help guys.

Not being able to hairpin is prob in itself but at least I know why items were crashing now.
Hi, I run The Demiurge server.

Code: Select all

PLS USE [code]CODE TAGS[/code] WHEN POSTING CODE
Image
Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live. - Martin Golding
DO NOT PRIVATE MESSAGE ME ABOUT BUGS

Post Reply