public ip address can't be accessed from LAN

Can't get the client or server set up? Ask here!
We're on Discord! https://discord.gg/4dgAzfC
Post Reply
icxb06
Posts: 13
Joined: Thu Aug 25, 2016 1:18 am

public ip address can't be accessed from LAN

Post by icxb06 » Mon Oct 24, 2016 7:41 am

Hi all, I already run my own server and step by step changing from local ip, LAN IP, and now I'm in the stage of settings my server with public IP. I have my pc with server and client running together, and I tried to connect my second laptop to my server, but my second laptop always fails to connect.
What I already tried so far for my second laptop:
-Changed zone ip in navicat under zone_settings
-Open port on my firewall (using private connection, not public one)
- using my LAN ip, local IP, WAN IP, with combination of --hairpin on windower settings
The second laptop never connected and there is an error code FFXI-3001

My goal is to able to join my friend and my nephew to join my server from outside of my LAN, but I also like to dual box from my own LAN.

What did I miss? please help, thank you for your help.

fnx
Posts: 51
Joined: Tue Feb 10, 2015 11:26 pm

Re: public ip address can't be accessed from LAN

Post by fnx » Mon Oct 24, 2016 10:12 am

Did you change the below in "login_darkstar.conf" to your servers intenal/LAN IP?

#--------------------------------
#TCP/IP parameters
#--------------------------------

login_data_ip: 10.0.0.11
login_view_ip: 10.0.0.11
login_auth_ip: 10.0.0.11

User avatar
demolish
Developer
Posts: 262
Joined: Thu Jul 26, 2012 7:12 am

Re: public ip address can't be accessed from LAN

Post by demolish » Mon Oct 24, 2016 2:48 pm

or just set all of the above to 0.0.0.0
<Giblet[NewBrain]> kj with this first step would be fine on my shit
Click here for a guide on scripting missions.

icxb06
Posts: 13
Joined: Thu Aug 25, 2016 1:18 am

Re: public ip address can't be accessed from LAN

Post by icxb06 » Mon Oct 24, 2016 11:22 pm

Hi all, thank you for your reply

fnx: is this the LAN ip or other things? Im sorry if you could explain it more to me, i really appreciate it

demolish: I already changed everything to 0.0.0.0, but still error ffxi 3001

and I noticed there is a weird message showing in my log-in server log message:
[23/Oct 00:39][1;36m[Debug][0m lobbydata_parse:Incoming Packet:[1;37m<a2>[0m from ip:<192.xxx.x.xxx>
[23/Oct 00:39][1;37m[Info][0m lobbydata_parse: zoneid:(117),zoneip:(2x.xxx.xxx-->my public IP),zoneport:(54230) for char:(21829)
[23/Oct 00:39][1;32m[Status][0m lobbydata_parse: client 192.xxx.x.xxx finished work with [1;32mlobbyview[0m

thank you for your help

User avatar
demolish
Developer
Posts: 262
Joined: Thu Jul 26, 2012 7:12 am

Re: public ip address can't be accessed from LAN

Post by demolish » Tue Oct 25, 2016 6:11 am

means your game server is unreachable for that client
make sure you've forwarded all the servers ports correctly and your zone_settings table is pointing to your external ip
<Giblet[NewBrain]> kj with this first step would be fine on my shit
Click here for a guide on scripting missions.

icxb06
Posts: 13
Joined: Thu Aug 25, 2016 1:18 am

Re: public ip address can't be accessed from LAN

Post by icxb06 » Tue Oct 25, 2016 5:01 pm

hi demolish,that could be it, but I already checked all server ports in my router and the zone settings in table already pointing to my external ip, is this something I need to configure in my windows firewall as well?

thank you.

cahib
Posts: 1
Joined: Tue May 21, 2019 11:19 am

Re: public ip address can't be accessed from LAN

Post by cahib » Thu May 23, 2019 1:29 pm

I know this is late, but in case someone stumbles on trhis thread looking for the answer to this problem. I was having the same issue where I'm running my server on a VM ubuntu 14.04 no problems. Can connect locally and play no issues (all this time while my zone ip was set up to the VM ip). I open the ports as mentioned to the public and my friend was able to connect up to the point of loading the game after character load/creation. Meanwhile I can log in fine locally. I changed the zone ip address to my external facing ip, and now I am having the issue he was having when logging in locally, but hes able to log in fine. When I set up my xiloader ip to my public one instead of the local one, i was able to connect with my friend. I have 2 profiles on my windower/xiloader. one connects locally settings and other internet settings. however you set up your zone ip to connect to, everyone has to use that same connection type.

tldr: make sure both you and your friend are either both connecting locally when zone ip set to local lan, if you want friends to join over internet, set up your xiloader to connect to your public ip (or domain) which should also be you zone map ip

Post Reply