Dsconnect and DSgame servers not launching.

Can't get the client or server set up? Ask here!
We're on Discord! https://discord.gg/4dgAzfC
Post Reply
Shade00
Posts: 3
Joined: Sun May 20, 2018 3:03 pm

Dsconnect and DSgame servers not launching.

Post by Shade00 » Sun May 20, 2018 3:08 pm

So I followed the set up guide from the wiki. As well as watching the videos on how to do it. Now obviously I missed something but can't figure out what. When I go to launch the servers they just open and shut almost instantly. The AH server will open but has errors. I am super new to all this so any help would be appreciated.

Delaide
Posts: 464
Joined: Sat Jun 14, 2014 8:58 am

Re: Dsconnect and DSgame servers not launching.

Post by Delaide » Sun May 20, 2018 8:23 pm

Please check your logs. They should be in the darkstar/logs folder.

Shade00
Posts: 3
Joined: Sun May 20, 2018 3:03 pm

Re: Dsconnect and DSgame servers not launching.

Post by Shade00 » Sun May 20, 2018 10:49 pm

Delaide wrote:Please check your logs. They should be in the darkstar/logs folder.

This is what the login server log says

[20/May 19:59][1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)

This is the game server log

[20/May] [19:59:59][1;32m[Status][0m do_init: map_config is reading - [1;32m[OK][0m
[20/May] [19:59:59][1;32m[Status][0m luautils::init:lua initializing... - [1;32m[OK][0m
[20/May] [19:59:59][1;32m[Status][0m do_init: sqlhandle is allocating[20/May] [19:59:59][1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)
[20/May] [19:59:59][1;32m[Status][0m [1;37mluautils::free[0m:lua free... - [1;32m[OK][0m

User avatar
demolish
Developer
Posts: 262
Joined: Thu Jul 26, 2012 7:12 am

Re: Dsconnect and DSgame servers not launching.

Post by demolish » Mon May 21, 2018 7:28 am

<Giblet[NewBrain]> kj with this first step would be fine on my shit
Click here for a guide on scripting missions.

Shade00
Posts: 3
Joined: Sun May 20, 2018 3:03 pm

Re: Dsconnect and DSgame servers not launching.

Post by Shade00 » Mon May 21, 2018 12:26 pm

Ty for the help. I will let you know how it turns out.

Hector
Posts: 3
Joined: Sun Apr 21, 2019 8:19 pm

Re: Dsconnect and DSgame servers not launching.

Post by Hector » Sun Apr 21, 2019 9:05 pm

I'm having the same issue, here is my log:

login-server.log

Code: Select all

[1;37m[Info][0m DarkStar[22/Apr 04:54][1;37m[Info][0m Console Silent Setting: 0
[22/Apr 04:54][1;32m[Status][0m The login-server-auth is [1;32mready[0m (Server is listening on the port 54231).

[22/Apr 04:54][1;32m[Status][0m The login-server-lobbydata is [1;32mready[0m (Server is listening on the port 54230).

[22/Apr 04:54][1;32m[Status][0m The login-server-lobbyview is [1;32mready[0m (Server is listening on the port 54001).

[22/Apr 04:54][1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)
map-server.log

Code: Select all

[1;37m[Info][0m DarkStar[1;32m[Status][0m do_init: begin server initialization... 		 - [1;32m[OK][0m
[22/Apr] [04:57:14][1;32m[Status][0m do_init: map_config is reading 		 - [1;32m[OK][0m
[22/Apr] [04:57:14][1;32m[Status][0m luautils::init:lua initializing... 		 - [1;32m[OK][0m
[22/Apr] [04:57:14][1;32m[Status][0m do_init: sqlhandle is allocating[22/Apr] [04:57:14][1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)
[22/Apr] [04:57:14][1;32m[Status][0m [1;37mluautils::free[0m:lua free... 	 - [1;32m[OK][0m
search-server.log

Code: Select all


 [1;37m========================================================

[0m [1;37mDSSearch-server

 [1;37m========================================================

[0m [1;32mAH task to return items older than 3 days is running
[0m[1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)
[1;31m[Error][0m cant connect
[1;35m[SQL][0m Can't initialize character set unknown (path: compiled_in)
[1;35m[SQL][0m DB error - MySQL server has gone away
SQL: SELECT T0.id,T0.itemid,T1.stacksize, T0.stack, T0.seller FROM auction_house T0 INNER JOIN item_basic T1 ON                             T0.itemid = T1.itemid WHERE datediff(now(),from_unixtime(date)) >=3 AND buyer_name IS NULL;
 Sent 0 expired auction house items back to sellers

I have checked the links but the only thing I understaned from there is how to find my.ini file, and when I did, I did not found the following line:

Code: Select all

skip-character-set-client-handshake
.

PS: mySQL version is 8.0.15

Any advice would be much appreciate it :)

Hector
Posts: 3
Joined: Sun Apr 21, 2019 8:19 pm

Re: Dsconnect and DSgame servers not launching.

Post by Hector » Sun Apr 21, 2019 11:01 pm

PS: mySQL version is 8.0.15
Yup ... that was my problem. Uninstalling 8 and installing 5.7 solves it.

Delaide
Posts: 464
Joined: Sat Jun 14, 2014 8:58 am

Re: Dsconnect and DSgame servers not launching.

Post by Delaide » Mon Apr 22, 2019 5:08 am

Why I specifically note in the guide not to use version 8...

Post Reply