The New Retail Update Crashes Client Side

Bug reports go here: https://github.com/DarkstarProject/darkstar/issues

Just talk about them here please.
Forum rules
POST BUG REPORTS HERE: https://github.com/DarkstarProject/darkstar/issues

Try to keep the noise down on the reports on github, emails go out for every post on a bug report. :-)
altalus
Posts: 136
Joined: Wed Nov 14, 2012 8:31 pm
Location: Montreal Qc, CAN

Re: The New Retail Update Crashes Client Side

Post by altalus » Mon Dec 17, 2012 10:15 am

If I didn't know the amount of effort it takes I would almost suggest to start a darkstar client :P

basiah
Posts: 9
Joined: Sat Dec 15, 2012 2:14 pm

Re: The New Retail Update Crashes Client Side

Post by basiah » Mon Dec 17, 2012 4:09 pm

Kirby I don't know if it provides a clue but WS's do still work through the use of macros.

Just not JA's

CaelThunderwing
Posts: 7
Joined: Tue Jul 31, 2012 9:06 pm

Re: The New Retail Update Crashes Client Side

Post by CaelThunderwing » Tue Dec 18, 2012 2:11 am

check my post in client setup, for now sadly its the only option we have 2 issues from the dec 12th update

Party Packet changed
packets indicating JA arent relying on offsets.

mvd1987
Posts: 112
Joined: Wed Oct 17, 2012 8:36 am

Re: The New Retail Update Crashes Client Side

Post by mvd1987 » Tue Dec 18, 2012 11:53 am

yes i tryed your game download :(

it chrashes directly.

i copyed it from a fresh copy, and started the mxi and ffxi-boot and it chrashed.

i tryed then to copy data folder from ffxi to playonline and then run the clients again and still a crash.

i had the same problem when i tryed to upload and download my gamefolder, i think it looses some data when you download it and it wont run then.

i really hope blue and the rest can fix it soon in the new rev so all new players can join again,

since im getting pm after pm from new players :(

greetings michael
Owner/GMLeader mvd1987/michaelvandun Fantasy World International Server

basiah
Posts: 9
Joined: Sat Dec 15, 2012 2:14 pm

Re: The New Retail Update Crashes Client Side

Post by basiah » Tue Dec 18, 2012 1:01 pm

michael just do a fresh retail update and repair files.

Then drop the 10 files flunkle provided into your directory and allow them to replace all.

That will fix all the crashing, then just have people use a macro for weaponskills.

Job abilties are still broken but thats it at this point.

I am a new player that started after the new update all this works for new players.

mvd1987
Posts: 112
Joined: Wed Oct 17, 2012 8:36 am

Re: The New Retail Update Crashes Client Side

Post by mvd1987 » Tue Dec 18, 2012 3:41 pm

nope i meant the game dowload of cea on the other post.

the download from mediafire, he uploaded the hole game file

and it isnt for me but all new players on my server
Owner/GMLeader mvd1987/michaelvandun Fantasy World International Server

User avatar
Virtualchronos
Posts: 53
Joined: Wed Dec 12, 2012 8:45 am

Re: The New Retail Update Crashes Client Side

Post by Virtualchronos » Tue Dec 18, 2012 7:16 pm

doesn't have any of those bugs since I created this patch

try to find which file is the cause of the crash by testing them one by one. I don't have the time to create another patch so if anyone wanna try that's how you should do

basiah
Posts: 9
Joined: Sat Dec 15, 2012 2:14 pm

Re: The New Retail Update Crashes Client Side

Post by basiah » Thu Dec 20, 2012 10:00 pm

No dev update? Really game breaking makes multiple classes unusable. :(

bluekirby0
Developer
Posts: 707
Joined: Sun Jul 22, 2012 12:11 am

Re: The New Retail Update Crashes Client Side

Post by bluekirby0 » Thu Dec 20, 2012 10:23 pm

If you go to the other topic I linked earlier you can see the progress on this issue. The hang-up is on handling the 0xAC packets which now appear to do nothing no matter how I form them. I can stop the crashes but I can't fix JAs not working.

hakusho
Posts: 49
Joined: Wed Nov 07, 2012 1:01 pm

Re: The New Retail Update Crashes Client Side

Post by hakusho » Fri Dec 21, 2012 3:05 am

Quick question about the update. I haven't updated the POL client so this shouldn't affect me right now. However, will I be required to update my client when the DSP Server is updated to handle the new packets or will it be made compatible with the new and old versions of POL?

Locked