r2182 build problem

Bug reports go here: https://github.com/DarkstarProject/darkstar/issues

Just talk about them here please.
Forum rules
POST BUG REPORTS HERE: https://github.com/DarkstarProject/darkstar/issues

Try to keep the noise down on the reports on github, emails go out for every post on a bug report. :-)
biboy
Posts: 42
Joined: Thu Oct 04, 2012 2:08 pm

r2182 build problem

Post by biboy » Fri Jan 04, 2013 11:29 am

hi Team,
the new build r2182 have problem loading the DSGame-server.exe, it loads then exits right away.I've checked the login user and password are correct, the login server and search server loads just fine. have a great day guys.

Vanyel
Posts: 31
Joined: Sun Jul 22, 2012 10:58 am
Location: New Brunswick, Canada

Re: r2182 build problem

Post by Vanyel » Fri Jan 04, 2013 11:31 am

In the past couple weeks there have been new sql tables added to the project. Are you sure you sure you have all of them added/updated in SQL?

biboy
Posts: 42
Joined: Thu Oct 04, 2012 2:08 pm

Re: r2182 build problem

Post by biboy » Fri Jan 04, 2013 1:22 pm

yeah I actually use clean up, and check everything then update to latest in tortoiseSVN. I would read up all the new .sql added in new rev and execute the added .sql before I rebuild, but if it fails, the 2nd step I always do will be I would delete the db and manually execute each .sql then build. But the r2182 DSGame-server still loads and exits right away. With the right user and password of coarse. Oh there's a r2183, I'm going to try that, brb. Thanks for your input.

metronet
Posts: 10
Joined: Mon Dec 03, 2012 7:46 pm

Re: r2182 build problem

Post by metronet » Fri Jan 04, 2013 1:47 pm

I had a similar issue where dsgame would crash after loading item_mods from the database, here is the strace output right before the Linux segfault:

Code: Select all

write(3, ",\0\0\0\3SELECT itemId, modId, value"..., 48) = 48
read(3, "\1\0\0\1\0039\0\0\2\3def\5dspdb\titem_mods\tit"..., 16384) = 16384
read(3, ">\00512211\003357\0012\v\0\0?\00512212\0011\00217\n\0\0@"..., 16384) = 16384
read(3, "\0\200\00512586\00258\0011\v\0\0\201\00512587\0011\00231\v\0\0\202"..., 16384) = 16384
read(3, "\0012\f\0\0\315\00513109\00210\2-5\v\0\0\316\00513109\00227\1"..., 16384) = 16384
read(3, "1\00212\0013\v\0\0\24\00513611\00213\0013\n\0\0\25\00513612\1"..., 16384) = 16384
read(3, "8\0011\00232\v\0\0Q\00513938\0012\00232\v\0\0R\00513938\2"..., 16384) = 16384
read(3, "14261\00211\0011\v\0\0\217\00514262\0011\00224\n\0\0\220\00514"..., 16384) = 16384
read(3, "\f\0\0\306\00514573\00213\2-3\f\0\0\307\00514573\00214\2-3"..., 16384) = 16384
read(3, "1\v\0\0\3\00514964\00225\0011\v\0\0\4\00514965\0011\00217\n"..., 16384) = 16384
read(3, "5248\003114\0015\r\0\0<\00515248\003115\00210\v\0\0=\5"..., 16384) = 16384
read(3, "12\0015\f\0\0{\00515637\003117\0015\f\0\0|\00515637\0031"..., 16384) = 16384
read(3, "1\v\0\0\276\00516094\00225\0011\v\0\0\277\00516095\0011\00212\v"..., 16384) = 16384
read(3, "073\00212\00210\f\0\0\3\00517073\00213\00210\v\0\0\4\00517"..., 16384) = 16384
read(3, "10\0013\v\0\0=\00518115\00225\0012\v\0\0>\00518116\00225"..., 16384) = 14630
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
I rolled back item_mods.sql back to an earlier version and all is well :)

Perhaps something to do with modId 369 & 370?

https://code.google.com/p/onetimexi/sou ... m_mods.sql

biboy
Posts: 42
Joined: Thu Oct 04, 2012 2:08 pm

Re: r2182 build problem

Post by biboy » Fri Jan 04, 2013 1:49 pm

same problem exists in r2183, DSGame-server loads then exits right away,

here's waht the maps-server.log says:

[1;32m[Status][0m Memory manager initialised: [1;37mlog/DSP.leaks[0m
[1;37m[Info][0m DarkStar - onetimexi - SVN Revision: [1;37mUnknown[0m.
[1;32m[Status][0m do_init: begin server initialization...
[10:41:25][1;37m[Info][0m Console Silent Setting: 0 - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m do_init: map_config is reading - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m luautils::init:lua initializing... - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m cmdhandler::init: initializing... - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m do_init: sqlhandle is allocating - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m do_init: zlib is reading - [1;32m[OK][0m
[10:41:25][1;32m[Status][0m do_init: loading items[10:41:25][1;32m[Status][0m [1;37mluautils::free[0m:lua free... - [1;32m[OK][0m
[1;32m[Status][0m Memory manager initialised: [1;37mlog/DSP.leaks[0m
[1;37m[Info][0m DarkStar - onetimexi - SVN Revision: [1;37mUnknown[0m.
[1;32m[Status][0m do_init: begin server initialization...
[10:41:42][1;37m[Info][0m Console Silent Setting: 0 - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m do_init: map_config is reading - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m luautils::init:lua initializing... - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m cmdhandler::init: initializing... - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m do_init: sqlhandle is allocating - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m do_init: zlib is reading - [1;32m[OK][0m
[10:41:42][1;32m[Status][0m do_init: loading items[10:41:43][1;32m[Status][0m [1;37mluautils::free[0m:lua free... - [1;32m[OK][0m
[1;32m[Status][0m Memory manager initialised: [1;37mlog/DSP.leaks[0m
[1;37m[Info][0m DarkStar - onetimexi - SVN Revision: [1;37mUnknown[0m.
[1;32m[Status][0m do_init: begin server initialization...
[10:42:14][1;37m[Info][0m Console Silent Setting: 0 - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m do_init: map_config is reading - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m luautils::init:lua initializing... - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m cmdhandler::init: initializing... - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m do_init: sqlhandle is allocating - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m do_init: zlib is reading - [1;32m[OK][0m
[10:42:14][1;32m[Status][0m do_init: loading items[10:42:14][1;32m[Status][0m [1;37mluautils::free[0m:lua free... - [1;32m[OK][0m

and that's all there is in the log since it's a new build. r2183

Thank you Team if anyone can check it.

metronet
Posts: 10
Joined: Mon Dec 03, 2012 7:46 pm

Re: r2182 build problem

Post by metronet » Fri Jan 04, 2013 2:00 pm

It looks like this issue started from r2180 and have you tried rolling back just item_mods.sql DB to an earlier version?

Not sure why your SVN Revision is unknown (on windows?) but here is my output after the .sql rollback:

Code: Select all

[Status] Memory manager initialised: log/DSP.leaks
[Info] DarkStar - onetimexi - SVN Revision: 2183.
[Status] do_init: begin server initialization...
[10:51:34][Info] Console Silent Setting: 0                      - [OK]
[10:51:35][Status] do_init: map_config is reading               - [OK]
[10:51:35][Status] luautils::init:lua initializing...           - [OK]
[10:51:35][Status] cmdhandler::init: initializing...            - [OK]
[10:51:35][Status] do_init: sqlhandle is allocating             - [OK]
[10:51:35][Status] do_init: zlib is reading                     - [OK]
[10:51:35][Status] do_init: loading items                       - [OK]
[10:51:35][Status] do_init: loading spells                      - [OK]
[10:51:35][Status] do_init: loading zones[10:51:37][Debug] UpdateWeather Finished
                      - [OK]
[10:51:37][Status] do_init: server is binding with port 54230   - [OK]
[10:51:37][Status] The map-server is ready to work...
=======================================================================

biboy
Posts: 42
Joined: Thu Oct 04, 2012 2:08 pm

Re: r2182 build problem

Post by biboy » Fri Jan 04, 2013 2:09 pm

thank you for the input, I have dual boot and on 1st drive is un updated client so it works still and my server rev on that one is r2179 and everything works fine, and on the 2nd drive, this one by the way is good for testing new builds, I thought I'm the only one having problem with the new build but it seems you encounter the same since 2180. So I guess, our devs will test this as well when they read our posts.

User avatar
kjLotus
Lead Developer
Posts: 1813
Joined: Sun Jul 22, 2012 2:16 pm

Re: r2182 build problem

Post by kjLotus » Fri Jan 04, 2013 10:18 pm

hmm.. 2180 works for me, 2183 works for me

worked for everyone else i talked to

can you just do what metro said, and put item_mods.sql to rev 2179 (and everything else 2180/2183, depending on client patch)?

it'll be hard for me to fix since i can't reproduce it

User avatar
Virtualchronos
Posts: 53
Joined: Wed Dec 12, 2012 8:45 am

Re: r2182 build problem

Post by Virtualchronos » Fri Jan 04, 2013 10:43 pm

got problem with 2180 too
each time I tried to update the game server crashes on "loading item" I successfully launched it one time and the server was messed up. NPC changes PJ into other races and changed their names too. Bastok icon apeared on a player and other stranges bugs so I tried again a couples of times and returned on rev 2179 where everything worked perfectly

User avatar
kjLotus
Lead Developer
Posts: 1813
Joined: Sun Jul 22, 2012 2:16 pm

Re: r2182 build problem

Post by kjLotus » Fri Jan 04, 2013 10:57 pm

Virtualchronos wrote:got problem with 2180 too
each time I tried to update the game server crashes on "loading item" I successfully launched it one time and the server was messed up. NPC changes PJ into other races and changed their names too. Bastok icon apeared on a player and other stranges bugs so I tried again a couples of times and returned on rev 2179 where everything worked perfectly

the messed up was rev. 2181

edit: with a july patch client - 2181 onwards is intended to be used with dec. patch, so it will be broken on july patch

can you guys test the item_mods crash on rev. 2180 only?

Post Reply