Linux compatibility in r2162

Bug reports go here: https://github.com/DarkstarProject/darkstar/issues

Just talk about them here please.
Forum rules
POST BUG REPORTS HERE: https://github.com/DarkstarProject/darkstar/issues

Try to keep the noise down on the reports on github, emails go out for every post on a bug report. :-)
Post Reply
metronet
Posts: 10
Joined: Mon Dec 03, 2012 7:46 pm

Linux compatibility in r2162

Post by metronet » Tue Jan 01, 2013 4:31 pm

This is really a minor issue and probably doesn't deserve it's own thread but I had to change line 28 in conquest_system.cpp to make it compile under Debian:

http://code.google.com/p/onetimexi/sour ... 162&r=2162

The error was that it could not find "lua\luautils.h" under Linux; after changing it to "lua/luautils.h" it started to compile.

Happy New Year! :)

lautan
Developer
Posts: 164
Joined: Mon Jul 30, 2012 6:17 pm

Re: Linux compatibility in r2162

Post by lautan » Tue Jan 01, 2013 9:19 pm

Thanks for that. I use linux too.

User avatar
kjLotus
Special Guest
Posts: 1813
Joined: Sun Jul 22, 2012 2:16 pm

Re: Linux compatibility in r2162

Post by kjLotus » Wed Jan 02, 2013 2:14 am

fixed, thanks

Post Reply